分享主题:linux,nginx,php,mysql

php7.4.1 No package ‘libpcre2-8’ found,php-fpm7.4.1 libpcre2-8 >= 10.30

php7 0评论 现在加入小程序俱乐部QQ群:483987340

in CentOS,
install php7.4.1,
some error like:

Package requirements (libpcre2-8 >= 10.30) were not met
No package ‘libpcre2-8’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PCRE2_CFLAGS
and PCRE2_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

centos install php7.4.1

what shoud i do

wget https://ftp.pcre.org/pub/pcre/pcre2-10.34.tar.bz2
tar xjvf pcre2-10.34.tar.bz2
./configure --prefix=/usr/local/pcre2 \
--enable-pcre2-16 \
--enable-pcre2-32 \
--enable-jit \
--enable-jit-sealloc

make && make install

export PKG_CONFIG_PATH=/usr/local/pcre2/lib/pkgconfig/

click here see more

声明:本文仅供交流学习 , 版权归属原作者,部分文章未能及时与原作者取得联系,若来源标注错误或侵犯到您的权益烦请告知QQ:58842997,我们会及时删除。
秦子恒公众号

来源:秦子恒博客,欢迎转载分享,请保留出处

php7.4.1 No package ‘libpcre2-8’ found,php-fpm7.4.1 libpcre2-8 >= 10.30链接:https://www.qinziheng.com/php7/8892.htm

现在就加入微信开发QQ群2:483987340,跟同行探讨微信公众平台开发。群满就关闭,你得等到下一个群开通才能加入……

喜欢 (0)